Antique Engines and Old Iron
[Home] - [HELP] - [Forums] - [Groups] - [Classified Ads] - [Subscribe] - [Books] - [Sponsors] -

Go Back   SmokStak > SmokStak® Antique Engine Community > Hit & Miss Gas Engine Discussion
Forgot Password? Join Us!

Notices

Hit & Miss Gas Engine Discussion Meet collectors of hit and miss engines, ask questions about collecting, restoring and showing antique flywheel engines.

Hit & Miss Gas Engine Discussion

Economy 1 1/2hp not running


this thread has 6 replies and has been viewed 1211 times

Reply
 
Thread Tools Display Modes
  #1  
Old 10-06-2009, 08:27:30 PM
jameslee jameslee is offline
Registered
 
Join Date: Jun 2009
Location: mayer minnesota
Posts: 47
Thanks: 34
Thanked 32 Times in 8 Posts
Default Economy 1 1/2hp not running

I have an economy 1 1/2hp it will firer for about 3-5 times and than die, i have never had it running for more than about 30 seconds. It has good spark and is getting gas. Any advice would be helpful Thanks
Reply With Quote
Sponsored Links
  #2  
Old 10-06-2009, 09:01:28 PM
Tony Page's Avatar
Tony Page Tony Page is offline
Subscriber
 
Join Date: Nov 2004
Location: South Carolina
Posts: 36
Thanks: 0
Thanked 13 Times in 9 Posts
Default Re: Economy 1 1/2hp not running

Sounds like a fuel problem,(you say the spark is good). If the exhaust is black you're too rich. If it sounds weak or pops you're too lean. On a new engine I start at 1/4 turn and go from there. Also make sure the check valve is working. Just a guess, Tony
PS: Some like to run with the choke partially on.
Reply With Quote
  #3  
Old 10-06-2009, 10:30:34 PM
Chris Steffen Chris Steffen is offline
Subscriber
 
Join Date: Sep 2009
Location: Modesto, California
Posts: 676
Thanks: 642
Thanked 2,164 Times in 305 Posts
Default Re: Economy 1 1/2hp not running

I had a similar problem with an engine of mine. It sounds like a fuel issue. If it starts again after it quits, more than likely it is not getting enough fuel. If it is troublesome to start after it dies it is probably flooded.
Reply With Quote
  #4  
Old 10-07-2009, 07:54:27 PM
Doug Hanneman's Avatar
Doug Hanneman Doug Hanneman is offline
Registered
 
Join Date: Nov 2004
Location: Wisconsin, USA
Posts: 231
Thanks: 406
Thanked 167 Times in 61 Posts
Default Re: Economy 1 1/2hp not running

I agree it is probably the fuel supply. I would just remove your fuel line and check valve, clean the check valve and make sure it operated smoothly because it can look ok but still be sticky, check the line to make sure it is open and put all back togeather. Good luck.
Reply With Quote
  #5  
Old 10-08-2009, 05:06:25 PM
jameslee jameslee is offline
Registered
 
Join Date: Jun 2009
Location: mayer minnesota
Posts: 47
Thanks: 34
Thanked 32 Times in 8 Posts
Smile Re: Economy 1 1/2hp not running

Thank you guys for the help hopefully i can get the engine running Thanks again James
Reply With Quote
  #6  
Old 10-08-2009, 07:43:09 PM
Chuck Ostrander Chuck Ostrander is offline
Registered
 
Join Date: Nov 2004
Location: Palominas, Arizona USA
Posts: 70
Thanks: 19
Thanked 27 Times in 22 Posts
Default Re: Economy 1 1/2hp not running

You did not say what model, I have a little 1 1/2 HP model N. I could get it to fire, but not run. Ended up I had to reduce the size of the fuel line and then it would run just fine.
Reply With Quote
  #7  
Old 10-09-2009, 05:01:13 PM
jameslee jameslee is offline
Registered
 
Join Date: Jun 2009
Location: mayer minnesota
Posts: 47
Thanks: 34
Thanked 32 Times in 8 Posts
Default Re: Economy 1 1/2hp not running

Its an Economy 1 1/2E
Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

F o r u m Jump

Similar Threads Chosen at Random
Thread Thread Starter F o r u m Replies Last Post
1 1/2 H.P. Economy running on propane Fred Van Hook Hit & Miss Gas Engine Discussion 5 12-25-2007 10:15:43 PM
Got the 1AJ running Bob E Onan Generators 4 11-13-2007 12:24:43 PM
Got it running.......... Rich Martz Hit & Miss Gas Engine Discussion 4 11-04-2007 10:23:11 PM
Running vs. non-running engines Chris Kirk Antique Engine Archives 19 12-22-2002 08:02:12 AM
my LA keeps running away! NICK Antique Engine Archives 4 05-12-2001 01:03:16 PM


Use "Ctrl" mouse wheel to change screen size.
All times are GMT -4. The time now is 05:42:35 AM.

Smokstak and Enginads site search!


All use is subject to our TERMS OF SERVICE
SMOKSTAK® is a Registered Trade Mark - A Community of Antique Engine Enthusiasts
Copyright © 2000 - 2019 by Harry Matthews P.O. Box 5612 - Sarasota, FL 34277